If you don't receive an activation email after registration, then please post in the help and support section with your screen name

This mod will NOT work with a pirated copy of Mount and Blade Warband!

Author Topic: Why does my game crash or have performance issues?!  (Read 7097 times)

Moose and 1 Guest are viewing this topic.

Offline RobatBerdetheon

  • Recruit
  • *
  • Posts: 1
  • Reputation: 0
    • View Profile
Re: Why does my game crash or have performance issues?!
« Reply #15 on: September 09, 2017, 08:43:36 AM »
Hey, im having a problem where my game will load and get to the main menu screen but no matter what I press it crashed right afterwards with "Mound and Blade Warband has stopped working"

Rob Lannister

  • Guest
Re: Why does my game crash or have performance issues?!
« Reply #16 on: September 12, 2017, 11:24:48 PM »
my game crashes when it starts to load. it appears an error: get_object failed for texture: manface_young

MJCAR

  • Guest
Re: Why does my game crash or have performance issues?!
« Reply #17 on: September 25, 2017, 08:47:23 PM »
A few people report issues with crashing. Here I will try and list the main reasons and things to try.



Make sure you are running the latest version of warband. This mod will only run correctly with version 1.172+.

An obvious one but make sure you are running the latest version of the mod. The latest version will always be linked at the very top of the boards.

Turn on 'Load textures on demand'

Make sure you are not running the game in edit mode.




If you experience stuttering but high fps then your cpu is probably not good enough to handle the formations ai. Try turning this off in the mod options.

If you have low fps then try turning your settings down in the game options.
Hey after your new update i am getting unbearable fps and at 1.2 i was getting really good fps did you let change the graphic engine and if so can you please have a version when the old one from 1.2 and before please or can you show use how if you dont have the time to do it over and upload it

Offline Gambit77

  • Recruit
  • *
  • Posts: 9
  • Reputation: 0
    • View Profile
  • Faction: The North
Re: Why does my game crash or have performance issues?!
« Reply #18 on: October 12, 2017, 02:09:05 AM »
I'm getting runtime CTDs regularly (almost always during screen transitions), and in the case of a battle to take King's Landing it CTDs every time I finish the first battle after hitting tab to proceed.  Here's a link to my save from right before the battle where it's a repeatable CTD, https://drive.google.com/open?id=0B0xe8NAN1WxPZUxieFNHOU1RN1k
My game is up to date, I've verified my files with Steam.
I've only used v2.2, first the download from Steam.  The in an attempt for stability after reading there was issues with the steam download, I switched to the the v2.0 and v2.2 hotfix from ModDB.
I've tried with textures on demand on, then tried with off, then tried with on again.
I've turned the cinematic view on town screen setting off.
I've lowered the battle size to 300, even though I've never had an issue running 750 with other mods.
I have an i7, 1080, and 16GB ram
Windows 10 is up to date.
Is there anything else I can try to make the game stable?
I really want to keep playing this because I love the mod, but the frustration with the crashing is unbearable.
I did use my save from starting with the Steam files when I switched to the ModDB files, could that be a problem?
« Last Edit: October 12, 2017, 02:51:43 AM by Gambit77 »

Offline H3YimDR3W

  • Knight
  • ***
  • Posts: 369
  • Reputation: 13
    • View Profile
  • Faction: The Free Cities
Re: Why does my game crash or have performance issues?!
« Reply #19 on: October 12, 2017, 07:02:38 AM »
I'm getting runtime CTDs regularly (almost always during screen transitions), and in the case of a battle to take King's Landing it CTDs every time I finish the first battle after hitting tab to proceed.  Here's a link to my save from right before the battle where it's a repeatable CTD, https://drive.google.com/open?id=0B0xe8NAN1WxPZUxieFNHOU1RN1k
My game is up to date, I've verified my files with Steam.
I've only used v2.2, first the download from Steam.  The in an attempt for stability after reading there was issues with the steam download, I switched to the the v2.0 and v2.2 hotfix from ModDB.
I've tried with textures on demand on, then tried with off, then tried with on again.
I've turned the cinematic view on town screen setting off.
I've lowered the battle size to 300, even though I've never had an issue running 750 with other mods.
I have an i7, 1080, and 16GB ram
Windows 10 is up to date.
Is there anything else I can try to make the game stable?
I really want to keep playing this because I love the mod, but the frustration with the crashing is unbearable.
I did use my save from starting with the Steam files when I switched to the ModDB files, could that be a problem?

It's not impossible for it to be a save issue, but it's highly unlikely, try a new save for an hour or so and see how you get on.

P.s - Export and Import Character if you don't want to lose character progress.
Got a question? PM me here. (I am in no way affiliated with this mod's development.)

Offline Gambit77

  • Recruit
  • *
  • Posts: 9
  • Reputation: 0
    • View Profile
  • Faction: The North
Re: Why does my game crash or have performance issues?!
« Reply #20 on: October 15, 2017, 12:02:18 AM »
Been trying a new game for a couple days and have only gotten a couple runtime CTDs and neither was repeatable, so it might be worth instructing people to not migrate their saves if they switch from Steam to ModDB files.

Noah

  • Guest
Re: Why does my game crash or have performance issues?!
« Reply #21 on: November 11, 2017, 02:35:35 AM »
So everytime I take over a castle, I get the 4 options.
A: Conquer and forbade plundering
B: Conquer and Plunder
C: Plunder and leave
D: Devastate
Everytime I do anything besides choice A my game will crash. Any ways to fix that?

Offline Tyson_48

  • Recruit
  • *
  • Posts: 7
  • Reputation: 0
  • Recruit
    • View Profile
Re: Why does my game crash or have performance issues?!
« Reply #22 on: November 15, 2017, 07:03:37 PM »
Perhaps this could help some...

I had random crashes with M&B and especially with the AWOIAF mod.
Checked dozens of graphics and chipset drivers, reinstalled the game several times and even the whole system.
Tested different graphics cards but this error and crashes remained and appeared completely random.

When i was about to change also the PSU on my PC i noticed a broken capacitor on the mainboard.
-> new mainboard -> all issues gone  ;)

This was totally weird because in all other applications even in newer games, i had no issues!
Only in AWOIAF --- as if this mod is so genius that it needed an extra capacitor on the board  ;D

To be serious it seems the M&B engine is very unstable and even a small hardware issue forces the game to crash even if much newer and powerful games do not suffer from this.

Noah

  • Guest
Re: Why does my game crash or have performance issues?!
« Reply #23 on: Today at 06:27:40 PM »
So now every time I try to plunder a village it will crash. It'll say charge the peasants or leave them be. I click charge, and the game crashes. Any suggestions?